En Blog

Llaman a actualizar plugins ante la salida de WordPress 2.1

Escrito el 12.12.2006 por Sebastián Thüer

Según se anunció horas atrás en el sitio de WordPress, el lanzamiento de la versión 2.1 de este sistema de blogs supondrá la actualización de los plugins. Muchos de los cambios de la nueva versión tienen que ver con la estructura de la base de datos, por lo cual los desarrolladores de plugins deberán tomar nota sobre como recorrer el contenido de las tablas.

Para el resto de los usuario, el cambio más importante tiene que ver con que el prefijo de las tablas que hasta ahora se encontraba en el archivo wp-config.php (el único archivo que hay que modificar "a mano" cuando se instala WordPress) será definido en una variable. También se agregará una columna a la tabla de los post para que sea más fácil distinguir si se trata realmente de un post o una página.

Para ayudar a los desarrolladores de plugins, la gente de WordPress ofrece un ejemplo paso a paso donde analizan un plugin y lo modifican para hacerlo compatible con la nueva versión. Por supuesto, los plugins que son afectos son aquellos que hacen uso de la base de datos. El resto no tendrá problemas.

Espero que esto no afecte demasiado la creación de temas. Estoy desarrollando uno desde cero y de a poco le estoy tomando la mano al asunto.